Modovi konfiguracije Cisco IOS-a

Tutorials za Informatičke mreže ( Windows LAN, CISCO, Router, Switch )
Locked
User avatar
IvanC
Administrator
Posts: 766
Joined: Tue Sep 20, 2005 9:54 am
Contact:

Modovi konfiguracije Cisco IOS-a

Post by IvanC » Fri Nov 14, 2008 11:27 am

Modovi konfiguracije Cisco IOS-a

Cisco uređaji koji rade na IOS softwareu konfiguriraju se u komandnoj liniji (CLI-command line interface) spajanjem na konzolni port ili telnetiranjem na uređaj.

Iz sigurnosnih razloga postoje dva nivoa pristupa:

User – služi provjeri stanja uređaja, nije moguće vršiti promjene u konfiguraciji.
Privileged – služi za konfiguraciju uređaja, moguć pristup svim naredbama.

Konfiguracija uređaja odvija se u modovima:

User EXEC mode

Prvi mod koji dobijete na uređaju je User EXEC mode koji ima slijedeći prompt:

Router


Privileged EXEC mode

U privileged EXEC mode ulazi se naredbom enable u user EXEC modu i upisom enable passworda ako je isti postavljen. Iz privileged moda izlazi se sa naredbom exit. Donji tekst prikazuje primjer korištenja tih naredbi:

Image

Router> enable
Password: [enable password]
Router# exit
Router>

Ostale naredbe privileged nivoa Cisco IOS-a hijerarhijski su strukturirane. Za uspješno konfiguriranje uređaja važno je razumjeti tu hijerarhiju. Na slijedećoj slici nalazi se shematski prikaz nekih IOS naredbi.

Help

Cisco IOS help je korisna pomoć za nove korisnike jer u svakom trenutku mogu naredbom ? pozvati pomoć. Pomoć se može koristi na dva načina:

Prvi način je da saznate koje sve naredbe počinju na neki dio riječi. Donji tekst prikazuje primjer korištenja tih naredbi:

Router# co?
configure connect copy

Drugi način je ispis svih naredbi u pojedinom modu komandne linije. Donji tekst prikazuje primjer korištenja tih naredbi:

Router# configure ?
memory Configure from NV memory
network Configure from a TFTP network host
overwrite-network Overwrite NV memory from TFTP network host
terminal Configure from the terminal
<cr>


Hot-Keys

Cisco IOS nudi nekoliko kratica za funkcije editiranja. Dolje su navedene kratice i njihove funkcije:

Delete - briše jedan znak desno od kursora.
Backspace - briše jedan znak lijevo od kursora.
TAB – završava nepotpunu naredbu.
Ctrl-A – pomiče kursor na početak linije.
Ctrl-U – briše cijelu liniju.
Ctrl-W – briše riječ.
Ctrl-Z - izlazi u Privileged EXEC mode.
Up Arrow - poziva prethodne naredbe.
Down Arrow - poziva slijedeće naredbe.


Možda je najbolji način da upoznate Cisco IOS CLI jest da prošetmo kroz jednostavnu konfiguraciju routera sa objašnjenjima svake naredbe:

Router> enable
*/ulazak u privileged EXEC mode/*

Router# configure terminal
*/ulazak u global configuration level/*

Router(config)# enable secret cisco
*/postavlja enable passworda na routeru/*

Router(config)# ip route 0.0.0.0 0.0.0.0 20.2.2.3
*/postavlja statičku IP rutu/*

Router(config)# interface ethernet0
*/ulazak u konfiguraciju ethernet0 interface-a/*

Router(config-if)# ip address 10.1.1.1 255.0.0.0
*/postavlja IP adrese na ethernet0 interface-u/*

Router(config-if)# no shutdown
*/aktivira ethernet0 interface/*

Router(config-if)# exit
*/povratak u globalni konfiguracijski mod/*

Router(config)# interface serial0
*/ulazak u konfiguraciju serial0 interface-a/*

Router(config-if)# ip address 20.2.2.2 255.0.0.0
*/postavlja IP adrese na ethernet0 interface-u/*

Router(config-if)# no shutdown
*/aktivira serial0 (interface)/*

Router(config-if)# exit
*/povratak u globalni konfiguracijski mod/*

Router(config)# router rip
*/konfigurira RIP routing protokol/*

Router(config-router)# network 10.0.0.0
*/dodaje mrežu 10.0.0.0/*

Router(config-router)# network 20.0.0.0
*/dodaje mrežu 20.0.0.0/*

Router(config-router)# exit
*/povratak u globalni konfiguracijski mod/*

Router(config)# exit
*/izlazi iz konfiguracijskog moda/*

Router# copy running-config startup-config
*/snima konfiguraciju u NVRAM/*

Router# disable
*/izlazi iz privileged EXEC moda/*
Router>

Prenešeno sa www.recro-net.hr/
Administrator foruma
IvanC

Locked

Who is online

Users browsing this forum: No registered users and 1 guest