Osnovna konfiguracija CISCO RUTERA - CCNA

Tutorials za Informatičke mreže ( Windows LAN, CISCO, Router, Switch )
Locked
User avatar
IvanC
Administrator
Posts: 765
Joined: Tue Sep 20, 2005 9:54 am
Contact:

Osnovna konfiguracija CISCO RUTERA - CCNA

Post by IvanC » Mon Jan 07, 2008 8:54 pm

Osnovna konfiguracija CISCO RUTERA
CISCO Router - CISCO RUTER
Uči se na CISCO Networking Academy za CCNA

ZABRANJENO JE OVU TEMU KOPIRATI NA DRUGE FORUME BEZ DOZVOLE ( http://www.ic.ims.hr )

Viđao sam početnike koji su postavljali pitanje, Što je to Ruter ( Router )? Čemu služi itd itd.
Mnogi neupućeni misle da je Ruter uređaj koji imaju kod kuće preko kojeg se spajaju i stalno ih asocira na kućni uređaj.
Ima više vrsta uređaja koje možemo nazvati Ruter pa tako za funkcije rutiranja može nam poslužiti i jedno desktop računalo ( PC ) sa određenim Operativnim sistemom ( npr PC sa OS Win2k ili 2003 ).
Sam uređaj specijalne namjene Ruter je ništa drugo do jedno računalo sa svim unutarnjim osnovnim komponentama i sa svojim Operativnim sistemom npr: IOS ( kod Cisco rutera )

Ovaj tutorial koji sam izradio po svom shvaćanju Rutera i njegove funkcije uči se na CISCO Networking Academy za CCNA.

Za čega služi Ruter ( eng. Router )?
Laički rečeno, Ruter spaja više različitih mreža tj. preusmjerava promet iz jedne mreže u drugu. Neki prevode Ruter kao USMJERENIK, jeste da Ruter usmjerava pakete ali ja više volim samu riječ Ruter i držat ću se nje.

Ruter jednostavno pomoću određenih protokola ( neki od poznatih su RIP, IGRP, OSPF, IS-IS itd. ) izračunava putanju do odredišta. Tako i Vi dok surfate Internetom, paketi koje šalje Vaše računalo prijeđu preko nekoliko desetaka Rutera da bi stigli do odredišta a uz to i vrate se nazad k Vašem računalu.

To se sve odvija vrlo brzo u mili-sekundama. Kada u Web browser upišete neku web adresu za kratko vrijeme Vam se pojavi dotična web stranica a niste možda ni svjesni da je nakon klika ili entera zahtjev Vašeg računala prošao kroz desetke Rutera u odlasku i povratku i usput mijenjao IP adresu.

Kako Izgleda Ruter ?
Kućni uređaj preko kojeg se spajate na Internet putem ADSL linije ili već kako također ima funkciju Rutera ali to nije uređaj na koji mislimo kada kažemo RUTER u Internet prometu i mreži.
Jedan od najpoznatijih komercijalnih proizvođača uređaja Rutera za Internet uporabu je tvrtka CISCO ( http://www.cisco.com ). U ovom tutorialu držat ću se CISCO rutera.

Evo jedna slika kako izgledaju Ruteri nekih serija Cisco.

Slika 1.
Image

Image

Kao što vidite na gornjoj slici to su uređaji koji na sebi imaju priključke ( ports / interfaces ).

Slika 1a. dočarat će upotrebu Rutera u Internet mreži. Oblak predstavlja neku veću mrežu. Npr: Internet a Računala, A, B, C mreže, dok gornja računala predstavljaju administrativne jedinice pomoću kojih možemo putem neke aplikacije ( npr: Hyper Terminal ) vršiti konfiguraciju Rutera.

Slika 1a.
Image

Kao što sam rekao Ruter u sebi ima sklopove slične one u jednom računalu ( PC-u ).
Na slici 2. možete uočiti neke osnovne unutrašnje elektroničke dijelove Rutera, a na slici 3 i 4. priključne konekcije sa stražnje strane rutera.

Slika 2.
Image

Slika 3.
Image

Slika 4.
Image

Ruter u Svom elektroničkom sklopovlju sadrži neke osnovne grupe koje su važne za rad i funkcioniranje Rutera. Slikovito ga možemo prikazati kao na slici 5.

Slika 5
Image

Osnovne značajke Rutera su:
RAM – RAM se koristi za usmjeravanje informacija iz tablice, brzo switchanje cache-a, pokretačku konfiguraciju i "stavljanje paketa u red na čekanje".
NVRAM – NVRAM se koristi za spremanje backup/startup konfiguracijske datoteke.
FLASH – Flash memorija se koristi za spremanje cijelog Cisco IOS softverskog image-a. ( operativnog sistema )
ROM – ROM se koristi za spremanje (za stalno) diagnostički startup code, kod podizanja sistema prilikom uključenja rutera..
CONSOLE – Consol port osigurava fizički pristup za priključak PC-a i administraciju Routera.
INTERFACES – Priključni portovi koji omogućuju LAN i WAN konekciju.

PRIKLJUČENJE PC-a ZA ADMINISTRACIJU RUTERA

Računalo ( PC ) priključuje se na Ruter preko Console porta pomoću tzv: Rollover kabla koji se spaja preko adaptera RJ45/DB9 . UTP utikač RJ-45 se priključuje na DB-9 adapter a adapter na COM port na računalu.

Kako izgleda Rollover kabal ? Pinovi se spajaju obrnuto 1-8 i 8-1 .

Slika 6.
Image

Slika 6a.
Image

Isto tako Rollover kabel služi za spajanje AUX porta i Modema preko RJ-45/DB25 adaptera.
Nakon uspješne konekcije na Ruter, pomoću programa npr: Hyper Terminal nakon podešavanja istog možemo pristupiti Comand Line Interfejsu ( CLI promptu ) na Ruteru.
Ovo "interfejs" nemojte shvatiti kao priključni port ( poput, serial, ethernet itd porta interface-a ). Ovdje riječ "interfejs" znači sučelje tj. komandna linija u kojoj pišemo naredbe. ( nešto slično poput DOS prompta )

Prije nego smo pristupili CLI promptu na Ruteru trebamo podesiti neke parametre za konekciju na COM portu računala. Vidi sliku 7.

Slika 7.
Image

Nakon pristupanja Comand Line Interfejsu pojavljuje nam se dio coda koji prikazuje da je Ruter uspješno startao i prompt koji je startna pozicija na Ruteru.
Postoje dva osnovna moda Rutera u kojima možemo raditi
- USER mode
- PRIVILEGED mode

User mode prompt izgleda ovako: Router> u njemu možete pregledavati neke postavke Rutera
Privileged mode prompt izgleda ovako: Router# u njemu možete re-konfigurirati Ruter

Koje sve naredbe možete utipkati u određenom modu? Za saznanje o istima dovoljno je utipkati upitnik ? i izlistat će Vam se sve naredbe koje u tom trenutku možete utipkati. Naravno da bi ste mogli raditi na konfiguraciji Rutera morate znati naredbe i što one izvršavaju. Da bi ste ušli u PRIVILEGED mode morate znati pristupnu lozinku ( ako je postavljena ).

OSNOVNA KONFIGURACIJA RUTERA

Da bi Ruter minimalno bio funkcionalan potrebno je postaviti određene parametre na njemu. Neki od njih su, Password, IP adrese Interface-a ( portova ), enkripciju passworda, sam naziv Rutera itd itd.

Opisat ću samo neke osnovne parametre kao i redoslijed konfiguracije Rutera.

Dakle, na Ruteru je potrebno konfigurirati slijedeće:

- Ime rutera ( Router name )
- Poruka dobrodošlice ili upozorenja ili slično ( prilikom konekcije na Ruter )
- Password za pristup preko Console porta ( Rollover kabla )
- Password za pristup preko Telnet linije ( pristup sa udaljenog rutera )
- IP adresa za pojedini Interface ( port za konekciju ) ( Serial, Ethernet ili FastEthernet ) + Subnet maska
- Opis pojedinog Interface-a ( description )
- Poruku nakon pristupa Ruteru ( Banners – login or message-of-the-day )
- Host tablicu tj. naziv susjednog Rutera i njegovu IP adresu ( Host Tables – koja je važna zbog pristupanja putem Telnet konekcije )
- Aktiviranje passworda na Ruteru
- Enkripciju za Password

Da bi mogli konfigurirati Ruter moramo ući iz "Privileged moda" u "Globalni konfiguracijski mod" ( #configure terminal )
Postoje i specifični SUB-modovi za pojedine parametre konfiguriranja

Slika 8.
Image

Pomoću simulatora za Ruter konkretno 1841 pokušat ću Vam prikazati kako se Ruter konfigurira sa osnovnom konfiguracijom ( Basic Ruter Configuring )

Prilikom bootanja ( startup Rutera ) pojavi se code koji od Vas traži da potvrdite Y ili N
Primjer za Ruter 1841 ( simulation )

Code: Select all

System Bootstrap, Version 12.3(8r)T8, RELEASE SOFTWARE (fc1)
Cisco 1841 (revision 5.0) with 114688K/16384K bytes of memory.

Self decompressing the image :
########################################################################## [OK]
              Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.
           170 West Tasman Drive
           San Jose, California 95134-1706

Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 12.3(14)T7, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Mon 15-May-06 14:54 by pt_team
Image text-base: 0x6007D180, data-base: 0x61400000

Port Statistics for unclassified packets is not turned on.
Cisco 1841 (revision 5.0) with 114688K/16384K bytes of memory.
Processor board ID FTX0947Z18E
M860 processor: part number 0, mask 49
2 FastEthernet/IEEE 802.3 interface(s)
191K bytes of NVRAM.
31360K bytes of ATA CompactFlash (Read/Write)
Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 12.3(14)T7, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Mon 15-May-06 14:54 by pt_team

         --- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: N  // potvrdite sa slovom "N" 
Press RETURN to get started!
Router>
Nakon pritiska tipke Enter pojavit će se "comand prompt" USER EXEC mode u kojem možete utipkati "?" a potomće Vam se izlistati sve naredbe koje možete izvršavati u tom modu. npr:

Code: Select all

Router>?
access-enable ……….. Create a temporary Access-List entry
access-profile ……….. Apply user-profile to interface
connect ……….. Open a terminal connection
disable ……….. Turn off privileged commands
disconnect ……….. Disconnect an existing network connection
enable ………..  Turn on privileged commands
exit ……….. Exit from the EXEC
help ……….. Description of the interactive help system
lock ……….. Lock the terminal
login ……….. Log in as a particular user
logout ……….. Exit from the EXEC
mrinfo ……….. Request neighbor and version information from a multicast router
mstat ……….. Show statistics after multiple multicast traceroutes
mtrace ……….. Trace reverse multicast path from destination to source
name-connection ……….. Name and existing network connection
pad ……….. Open a X.29 PAD connection
ping ……….. Send echo messages
ppp ……….. Start IETF Point-to-Point Protocol (PPP)
resume ……….. Resume an active network connection
rlogin ……….. Open an rlogin connection
Show ……….. Show running system information
slip ……….. Start a Serial-line IP (SLIP)
systat ……….. Display information about terminal lines
telnet ……….. Open a telnet connection
terminal ……….. Set terminal line parameters
traceroute ……….. Trace route to destination
tunnel ……….. Open a tunnel connection
udptn ……….. Open an updtn connection
x28 ……….. Become an X.28 PAD
x3 ……….. Set X.3 parameters on PAD
Za razliku kada isti znak upitnika "?" utipkate u Privileged modu

Code: Select all

Router#?
access-template	…………	Create a temporary Access-List entry
alps	…………	ALPS exec commands
archive	…………	manage archive files
bfe	…………	For manual emergency modes setting
cd	…………	Change current directory
clear	…………	Reset functions
clock	…………	Manage the system clock
configure	…………	Enter configuration mode
copy	…………	Copy from one file to another
debug	…………	Debugging functions (see also 'undebug')
delete	…………	Delete a file
dir	…………	List files on a filesystem
disable                 	…………
disconnect	…………	Disconnect an existing network connection
elog	…………	Event-logging control commands
erase	…………	Erase a filesystem
exit                    	…………
logout	…………	Exit from the EXEC
more	…………	Display the contents of a file
mrm	…………	IP Multicast Routing Monitor Test
ncia	…………	Start/Stop NCIA Server
ping	…………	Send echo messages
pwd	…………	Display current working directory
reload	…………	Halt and perform a cold restart
restart	…………	Restart Connection
resume	…………	Resume an active network connection
rsh	…………	Execute a remote command
sdlc	…………	Send SDLC test frames
send	…………	Send a message to other tty lines
setup	…………	Run the SETUP command facility
show	…………	Show running system information
start-chat	…………	Start a chat-script on a line
telnet	…………	Open a telnet connection
traceroute	…………	Trace route to destination
undebug	…………	Disable debugging functions (see also 'debug')
verify	…………	Verify a file
write	…………	Write running configuration to memory, network, or terminal
Ovo je samo jedan dio naredbi na Ruteru serije 1700 ( a vjerojatno ih ima još )

Nakon toga ulazite u Privileged mode , naravno ovo je sve pod pretpostavkom da konfiguriramo potpuno nekonfigurirani Ruter dakle od nule ;-)
Jedna od često upotrebljavanih naredbi je "SHOW" pomoću koje možemo vidjeti konfiguraciju Rutera ili pojedinih parametara.

Za ovu priliku konfigurirat ću Ruter 1721 pod imenom imenom Vinkovci-2 na slici 9.

Slika 9.
Image



Prije svake konfiguracije Rutera poželjno je pogledati trenutnu konfiguraciju, radi uvida u nazive Interface-a i ostalih parametara.

Trenutna konfiguracija našeg Rutera izgleda ovako: Trebate uočiti da Ruter Vinkovci-2 ima jedan serial Interface a Vinkovci-1 ima dva serial Interface-a.

Code: Select all

Router>
Router>enable
Router#show running-config 
Building configuration...
!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
ip subnet-zero
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface FastEthernet0
 no ip address
 no ip directed-broadcast
 bandwidth 100000
 shutdown
!
ip classless
no ip http server
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end
Idemo ga re-konfigurirati

Router>
Router>enable // ulazak u Privileged mode
Router#configure terminal // ulazak u global config mode
Router(config)#hostname Vinkovci-2 // postavljanje imena Rutera
Vinkovci-2(config)#
Vinkovci-2(config)#banner motd #Dobrodosli na Router Vinkovci-2# // poruka dana
Vinkovci-2(config)#line console 0 // ulazak u console line mode
Vinkovci-2(config-line)#password cisco // postavljanje password za ulaz preko console mode "cisco"
Vinkovci-2(config-line)#login // logiranje za postavljenu password
Vinkovci-2(config-line)#exit
Vinkovci-2(config)#line vty 0 4 // postavljanje password za ulaz preko Telnet konekcije
Vinkovci-2(config-line)#password cisco
Vinkovci-2(config-line)#login
Vinkovci-2(config-line)#exit
Vinkovci-2(config)#enable password cisco // aktiviranje passworda "cisco"
Vinkovci-2(config)#enable secret class // postavljanje passworda za ulaz u Privileged mode
Vinkovci-2(config)#ip host Vinkovci-1 192.168.4.17 // ime susjednog Rutera i IP adresa
Vinkovci-2(config)#exit
Vinkovci-2#clock set 18:46:00 1 May 2006 // postavljanje vremena na Ruteru
Vinkovci-2#copy running-config startup-config // snimanje promjena konfiguracije

Ovo bi bila osnovna početna konfiguracija Rutera Vinkovci-2.
Za provjeru konfiguracije koju smo upravo napravili potrebno je izaći iz Global-config moda u Privileged mode i upisom naredbe Vinkovci-2#show running-config provjeriti trenutnu konfiguraciju Rutera.

Ona sada izgleda ovako:

Code: Select all

Vinkovci-2#show running-config
Building configuration...
!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Vinkovci-2
enable secret 5 $sdf$6978yhg$jnb76sd
enable password cisco
!
ip subnet-zero
ip host Vinkovci-1 192.168.4.17
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface FastEthernet0
 no ip address
 no ip directed-broadcast
 bandwidth 100000
 shutdown
!
ip classless
no ip http server
!
banner motd ^C Dobrodosli na Router Vinkovci-2 ^C
line con 0
 login
 transport input none
 password cisco
line aux 0
line vty 0 4
 login 
 password cisco
!
no scheduler allocate
end
Ako radite sa AUX portom onda je potrebno postaviti password i za dotični ( slično kao za "line console 0" ili "line vty 0 4"

S obzirom da je Ruter Vinkovci-2 DTE uređaj nećemo postavljati "clock rate", on se postavlja na DCE uređaju ( Vinkovci-1 ), a naredba se postavlja na Serial1 interface-u koji je konektiran na Vinkovci-2.
Ista glasi Vinkovci-1(config-if)#clock rate 64000 // ili npr:56000. Ova postavka je obavezna između dva rutera kod Point-to-Point SERIAL konekcije jer je jedan Ruter uvijek DCE a drugi DTE.

Ostaje nam postaviti IP adrese na Interface-ima ( portovima ), obavezno ih aktivirati ( tj. uključiti a laički rečeno "podignuti" ) i postaviti opis na FastEthernet portovima prema LAN-u

Vinkovci-2#configure terminal
Vinkovci-2(config)#interface serial 0 // ulazak u Interface mode na serial 0 portu
Vinkovci-2(config-if)#ip address 192.168.4.18 255.255.255.252 // postavljanje IP adrese i subnet-maske za dotični Interface
Vinkovci-2(config-if)#no shutdown // aktiviranje interface-a
Vinkovci-2(config-if)#description Serial konekcija prema Vinkovci-1 // postavljanje opisa na Interface-u
Vinkovci-2(config-if)#exit
Vinkovci-2(config)#interface fastetheernet 0
Vinkovci-2(config-if)#ip address 172.17.2.1 255.255.255.0
Vinkovci-2(config-if)#no shutdown
Vinkovci-2(config-if)#description LAN konekcija na mrezu 172.17.2.0
Vinkovci-2(config-if)#exit
Vinkovci-2(config)#exit
Vinkovci-2#copy running-config startup-config

Sada smo završili osnovnu konfiguraciju Rutera i ona izgleda ovako:

Code: Select all

Vinkovci-2#show running-config
Building configuration...
!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Vinkovci-2
enable secret 5 $sdf$6978yhg$jnb76sd
enable password cisco
!
ip subnet-zero
ip host Vinkovci-1 192.168.4.17
!
interface Serial0
 description Serial konekcija prema ruteru Vinkovci-1
 ip address 192.168.4.18 255.255.255.252
 no ip directed-broadcast
!
interface FastEthernet0
 description LAN konekcija na mrezu 172.17.2.0
 ip address 172.17.2.1 255.255.255.0
 no ip directed-broadcast
 bandwidth 100000
!
ip classless
no ip http server
!
banner motd ^C Dobrodosli na Router Vinkovci-2 ^C
line con 0
 login
 transport input none
 password cisco
line aux 0
line vty 0 4
 login 
 password cisco
!
no scheduler allocate
end
Ako ste se ikada zamislili i poželjeli administrirati mreže, nadam se da će Vam ovaj tutorial pomoći eventualno ako ste dvoumili upisati ili ne Cisco Networking Academy za CCNA ili ste pak tek upisali :wink:
Administrator foruma
IvanC

Locked

Who is online

Users browsing this forum: No registered users and 1 guest